Dependencies for Offline Installation - Installation Guide - 6.9 - Cortex XSOAR - Cortex - Security Operations

Cortex XSOAR Installation Guide

Product
Cortex XSOAR
Version
6.9
Creation date
2022-09-01
Last date published
2024-02-07
End_of_Life
EoL
Category
Installation Guide

You need to install the following dependencies when installing Cortex XSOAR offline.

Note

The following is a list of top level dependencies. These dependencies may be dependent upon other OS libraries.

RPM dependencies

The following dependencies are required for Red Hat and CentOS deployments.

  • systemd

  • xmlsec1

  • xmlsec1-openssl

  • rpm-build

  • libcap

  • dnf-utils

  • file

  • fontconfig

  • expat

  • libpng

  • freetype

  • git

  • makeself

(Red Hat v8 & above) You also need to install Podman by running the following commands:

  • sudo yum -y install slirp4netns fuse-overlayfs

  • sudo yum -y module install container-tools

Debian Dependencies

The following dependencies are required for Debian and Ubuntu deployments.

  • systemd

  • xmlsec1

  • rpm

  • libcap2-bin

  • file

  • libfontconfig1

  • libexpat1

  • libfreetype6

  • git

  • makeself